CCH Axcess

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 15:27 EST

Identified

Feedback we have received from CCH support indicates they are aware of Axcess issues experienced by some customers today. Users may now see improvement after starting a new cloud session and relaunching their Axcess applications.
Posted Nov 10, 2025 - 12:41 EST

Investigating

We are aware some users are experiencing performance issues with CCH Axcess. Our teams are currently investigating, and have engaged CCH support. We will provide updates as we receive more information.
Posted Nov 10, 2025 - 11:40 EST