Microsoft Connectivity Issues

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 17:27 EDT

Update

Microsoft continues to report service degradation across several Microsoft services which may impact your ability to use Microsoft applications and/or launch applications from the Rightworks portal. If you are experiencing issues launching applications, please use our backup site https://backup.cloud.rightworks.com

Further details regarding this issue can be found at https://status.cloud.microsoft/
Posted Jul 23, 2026 - 15:40 EDT

Monitoring

We are currently hearing reports of connectivity issues with Microsoft services.
Issues with launching applications from the Cloud Portal have been reported.
In the instance this is impacting you, please use the backup portal and launch applications from backup.cloud.rightworks.com
Posted Jul 23, 2026 - 12:37 EDT