CCH Axcess: Degraded Performance

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 22:12 EDT

Monitoring

At this time, we are seeing reports of Axccess slowness and freezing decline. We continue to monitor the situation closely and are awaiting further input from CCH in determining root cause. If you are continuing to experience issues, please contact our support team so we can further assist.
Posted Sep 02, 2026 - 14:14 EDT

Investigating

Our teams are currently investigating reports of slowness and freezing with CCH Axcess. We will provide further details as more information becomes available.
Posted Sep 02, 2026 - 12:11 EDT