Issue Launching Applications

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Feb 21, 2026 - 10:24 EST

Monitoring

Affected uesrs should now be able to launch applications. If you continue to experience issues, please contact our support team so we can further assist you.
Posted Feb 21, 2026 - 08:32 EST

Identified

We have identified the issue and a fix is being deployed.
Posted Feb 21, 2026 - 08:03 EST

Investigating

We are aware some users are having issues launching applications from within their Rightworks portal. Our teams are actively investigating the issue.
Posted Feb 21, 2026 - 07:52 EST