Launching Applications

Incident Report for Rightworks Premier

Resolved

The issue affecting some users' ability to launch applications has been successfully resolved. Users who continue to experience any difficulties are encouraged to contact our support team for further assistance.
Posted Jun 06, 2025 - 13:28 EDT

Identified

We have identified the issue that is impacting some users' ability to launch applications. Our team is actively working on a resolution and we will continue to share updates as they become available.
Posted Jun 06, 2025 - 12:37 EDT

Investigating

We are currently aware of an issue affecting the ability of some users to launch applications. Our technical teams are actively investigating the matter and will provide additional updates as soon as they become available.
Posted Jun 06, 2025 - 11:46 EDT