Portal Login Issue

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted May 13, 2026 - 11:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Users should now be able to access the live portal site as normal.

If you continue to experience issues, please contact our support team so we can further assist.
Posted May 13, 2026 - 10:24 EDT

Investigating

We are aware some users are experiencing issues logging into their Rightworks portal. Our teams are actively investigating the issue. In the meantime, please access your applications via our backup site - https://backup.cloud.rightworks.com
Posted May 13, 2026 - 10:05 EDT