Citrix Pop-Up Message

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 11:47 EST

Monitoring

A fix has been implemented to resolve the Citrix pop-up seen by some users when launching applications. Please contact our support team if you experience any further issues.
Posted Dec 01, 2025 - 10:44 EST

Identified

We are aware some users are seeing a Citrix pop-up when launching applications. Our teams are working to resolve this message. In the meantime, users should be able to click 'OK' and launch applications as normal.
Posted Dec 01, 2025 - 09:59 EST