Ultratax Desktop Setup Message

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Nov 22, 2023 - 12:49 EST

Update

We have completed our work to correct this issue and our testing shows positive results. We will continue to monitor for any issues this morning before marking this incident as resolved.
Posted Nov 22, 2023 - 08:01 EST

Monitoring

We will be continuing to apply the UT fix into the evening and overnight hours. We expect this to be resolved for all firms tomorrow (11/22) morning.
Posted Nov 21, 2023 - 17:31 EST

Update

We are continuing to deploy the UltraTax fix for firms. We will update status when the fix has been deployed to all firms.

If your firm has received the fix, and you need assistance setting up the new two-factor authentication method for your TR account, please refer to TR's guide: https://www.thomsonreuters.com/en-us/help/account-management/set-up-two-factor-authentication.html
Posted Nov 21, 2023 - 12:24 EST

Update

Our team is working to deploy a fix for all firms that are unable to launch UltraTax. We will update this message once the fix is completely deployed.
Posted Nov 21, 2023 - 10:07 EST

Identified

Our teams are working on and testing a solution.
Posted Nov 21, 2023 - 09:00 EST

Investigating

Our teams are investigating an issue with opening Ultratax for some users.
Posted Nov 21, 2023 - 08:23 EST