Portal Login
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Jan 10, 2024 - 11:23 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 10, 2024 - 10:48 EST
Identified
There is an issue with users logging into the portal currently. Please use https://backup.cloud.rightworks.com if you are not able to get into the portal. Our teams are investigating the cause of this problem.
Posted Jan 10, 2024 - 10:13 EST