Application Launch Error Message

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted May 30, 2026 - 23:22 EDT

Monitoring

Our team has completed the work to address this issue. Please call our support team if you experience any issues.
Posted May 30, 2026 - 15:35 EDT

Update

Some users may continue to see the unspecified error when trying to launch an application from the cloud portal. Our team is actively working to resolve this issue.
Posted May 30, 2026 - 09:52 EDT

Identified

Some users are receiving the following error when launching an application from the cloud portal: "An unspecified error occurred during application launch. Please try again". Our team is aware of the issue and is working on a fix that will be rolled out to all affected users.
Posted May 30, 2026 - 07:50 EDT