Phone and Chat systems
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 09:43 EST
Monitoring
We are seeing restored performance for our phone and chat services and are continuing to monitor.
Posted Nov 20, 2024 - 09:23 EST
Update
Our vendor that we rely on for phone and chat for Sales, Billing and Technical Support is experiencing technical issues. Calls and chats do seem to be entering the system, however our staff is unable to log in to receive them. Our vendor has updated us that they are beginning to implement mitigation steps. We apologize for this inconvenience and will update this status page with more information as it becomes available.
Posted Nov 20, 2024 - 08:50 EST
Identified
Our vendor reports they have identified the issue and are working on remediation.
Posted Nov 20, 2024 - 08:33 EST
Investigating
Our phone and chat vendors are reporting problems which are limiting our ability to answer incoming requests. We will post further updates as soon as available.
Posted Nov 20, 2024 - 08:25 EST