Cloud Portal Login Issue
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Dec 05, 2023 - 20:58 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2023 - 19:40 EST
Investigating
We have received reports that some users are receiving a "404 error" when attempting to login to the cloud portal website. Our teams are currently investigating. If you are unable to login, please utilize the backup site https://backup.cloud.rightworks.com/
Posted Dec 05, 2023 - 19:14 EST