Phone Support
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Dec 05, 2023 - 16:04 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2023 - 14:44 EST
Identified
This issue seems to be related to our toll-free number which we are working to resolve. In the meantime, please call 678-297-0066 to reach support.
Posted Dec 05, 2023 - 13:31 EST
Investigating
We are reviewing potential problems with our phone service. Our teams are in contact with our vendor to investigate.
Posted Dec 05, 2023 - 13:24 EST