Our portal systems remain fully operational. A change has been made that we hope will prevent any further recurrence; however, our teams continue to monitor closely and remain engaged with our vendor as we continue to investigate root cause.
Posted Oct 06, 2025 - 19:45 EDT
Monitoring
Portal access has been restored. Users can now access the primary portal site normally. Our teams continue to monitor to ensure normal behavior of our portal systems.
Posted Oct 06, 2025 - 17:17 EDT
Identified
Our teams remain actively engaged as we work to address an issue affecting portal access. Application availabilty is not impacted. Affected users can access their applications via our backup site - https://backup.cloud.rightworks.com/login
Posted Oct 06, 2025 - 16:54 EDT
Investigating
Our teams are actively investigating reports of some users being unable to access their Rightworks portal. Affected users can access their applications using our backup site - https://backup.cloud.rightworks.com/login