CCH Axcess Issues
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 21:28 EST
Update
CCH is now reporting the issue has spread to the entire Axcess suite. CCH Status Page https://support.cch.com/oss/ml/appstatus
Posted Jan 18, 2024 - 18:04 EST
Monitoring
CCH has reported via their status page that some customers may be experiencing degraded performance, including errors when opening a return or logging in. They report Axcess Tax, Axcess Document, and Axcess Practice as the applications within the Axcess suite that are having these issues. They are working to identify the issue. CCH Status Page https://support.cch.com/oss/ml/appstatus
Posted Jan 18, 2024 - 17:46 EST