Disruption in DUO Features

Incident Report for Rightworks OneSpace Firm Premier

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 20:21 EST

Update

We are continuing to see successful recovery of DUO services for our users. If you are still experiencing issues with your DUO authentication, please call or chat our support team so we can assist you.
Posted Feb 13, 2025 - 18:34 EST

Update

Our users are beginning to see authentication issues resolve based upon DUO's most recent update - https://status.duo.com/incidents/h7lht3g1zv9w If you have been impacted by this issue, please try logging in again.
Posted Feb 13, 2025 - 17:20 EST

Update

Our teams are continuing to closely monitor the DUO incident, which is preventing some users from successfully authenticating when logging into their Rightworks account. We will continue to relay information as DUO provides further updates - https://status.duo.com/incidents/h7lht3g1zv9w
Posted Feb 13, 2025 - 17:03 EST

Update

DUO reports they have identified the issue and are working to deploy a fix - https://status.duo.com/incidents/h7lht3g1zv9w

If able, DUO suggests utilizing non-telephony-based MFA methods to ensure proper access until fix is deployed.
Posted Feb 13, 2025 - 14:47 EST

Monitoring

DUO is investigating the issue. Please see their status page for further updates. https://status.duo.com/incidents/h7lht3g1zv9w

If you are able to, DUO recommends utilizing Push, or Passcode methods in the meantime.
Posted Feb 13, 2025 - 13:54 EST

Investigating

Our teams are reviewing an issue with DUO allowing log ins. For some users, the text and call features are not operational. We will provide updates as they become available.
Posted Feb 13, 2025 - 13:44 EST