Undeliverable Email
Incident Report for Rightworks OneSpace Firm Premier
Resolved
We will be working with clients individually to put records in place with their DNS hosts to address this issue.
Posted Mar 11, 2024 - 18:47 EDT
Monitoring
In order to correct this problem, we are being advised that using DKIM will address the issue. The article below walks through this process. Our team is looking into how to best address this for our firms.

https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/email-authentication-dkim-configure?view=o365-worldwide
Posted Mar 11, 2024 - 15:55 EDT
Identified
Microsoft has released a notice that some emails sent to AOL and Yahoo domains may be marked as spam and will not be delivered. Remediation is in progress and in the mean time users will receive a bounce back message if this occurs.
Posted Mar 11, 2024 - 08:14 EDT