CCH Axcess Accessibility Issues

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 14:04 EDT

Identified

CCH has posted an update to their status page, and we continue to closely monitor the situation with them.
Posted Sep 11, 2026 - 11:58 EDT

Investigating

Multiple firms are reporting issues accessing and using CCH Axcess. Our teams are actively monitoring the situation and reviewing available information. For the latest updates on CCH Axcess service status, please visit the CCH Axcess Status Page: https://support.cch.com/oss/ml/appstatus
Posted Sep 11, 2026 - 11:00 EDT