Cloud Portal Login & Application Availability
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 09:26 EST
Monitoring
At this time we believe this problem was related to an issue at our vendor, Duo. The problems seem to be resolved at this time.
Posted Dec 04, 2023 - 08:14 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 04, 2023 - 07:58 EST
Investigating
Our teams are currently investigating an issue with logging into the cloud.rightworks.com portal along with some reports of applications not launching. Please check back for updates.
Posted Dec 04, 2023 - 07:40 EST