CCH Axcess Tax - Accessibility Issues

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 20:05 EDT

Identified

As of 2:55pm ET, CCH indicated that users may be experiencing intermittent issues opening CCH Axcess Tax. CCH is investigating. For the latest updates on CCH Axcess service status, please visit the CCH Axcess Status Page: https://support.cch.com/oss/ml/appstatus
Posted Sep 15, 2026 - 15:11 EDT