The necessary work has been completed by our teams. Please contact support if you continue to experience any issues opening word-based workpapers within Pfx Engagement so we can further assist you.
Posted Jun 12, 2026 - 06:39 EDT
Update
A recent Windows update introduced changes affecting users' ability to open word-based workpapers within Pfx Engagement. Our teams are working to roll back the problematic Windows update for affected firms, and we expect this work to be completed overnight. If you need this issue addressed sooner, please contact our support team so we can coordinate with you.
Our team is working to deploy a change recommended by CCH to address this issue. We will continue to share updates as they become available.
Posted Jun 10, 2026 - 18:47 EDT
Monitoring
We are currently seeing reports of users unable to open Word documents in Pfx Engagement. CCH has confirmed this is a known issue, and their development team is actively working on a resolution. We will continue to monitor and share updates as they become available.