CCH Axcess Tax

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 15:52 EDT

Update

CCH reports the issue has been resolved and Return Manager services are now functioning normally. If you are still experiencing issues, please contact our support team so we can further assist you.
Posted Mar 09, 2026 - 15:06 EDT

Monitoring

We are aware some users are experiencing intermittent issues with loading Return Manager in CCH Axcess Tax. CCH is aware of the issue and investigating - https://support.cch.com/oss/ml/appstatus
Posted Mar 09, 2026 - 13:50 EDT