Portal log in

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 09:02 EDT

Monitoring

The fix has been deployed successfully. If you previously experienced issues logging into the portal website, please try again. If you continue to encounter any problems with your login, please contact our support team.
Posted Jul 02, 2025 - 08:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2025 - 08:09 EDT

Investigating

Our teams are looking into issues logging into the portal. Please try https://backup.cloud.rightworks.com/login if you are having problems with log in.
Posted Jul 02, 2025 - 07:46 EDT