CCH Applications: Service Disruption

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 12:40 EDT

Update

CCH reports affected services have returned to normal at this time.
Posted Aug 28, 2025 - 12:35 EDT

Monitoring

CCH is reporting service disruption across some of their applications. Please see their status page for further details - https://support.cch.com/oss/ml/appstatus
Posted Aug 28, 2025 - 12:21 EDT