Microsoft 365 Service Degradation

Incident Report for Rightworks Premier

Resolved

Microsoft has closed the incident. Microsoft Outlook and Teams issues should now be resolved. https://status.cloud.microsoft/
Posted Oct 09, 2025 - 16:39 EDT

Monitoring

Microsoft reports some users are experiencing service degradation for M365 services and features. More details can be found via their status - https://status.cloud.microsoft/
Posted Oct 09, 2025 - 15:15 EDT