TR: NetClient and NetFirm CS
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 17:40 EST
Update
Thompson Reuters has completed their emergency work and has marked their incident as monitoring.

https://taxprofessionals-status.hostedtax.thomsonreuters.com/incidents/zrgkzk8hqx1b
Posted Nov 22, 2023 - 08:00 EST
Monitoring
TR has reported that some customers are experiencing degraded performance when accessing NetFirm CS. Users may experience delays logging in and performing login resets. They are currently investigating the issue. Please see their status page for further updates.
https://taxprofessionals-status.hostedtax.thomsonreuters.com/
Posted Nov 21, 2023 - 11:51 EST