Exchange Online

Incident Report for Rightworks Premier

Resolved

Microsoft is indicating that most users are functioning normally. We will continue to monitor for changes.
Posted Sep 02, 2026 - 09:30 EDT

Investigating

Microsoft continues to report issues with email, as well as other 365 services. For additional information visit https://status.cloud.microsoft/en-us/status
Posted Aug 31, 2026 - 18:39 EDT