Unable to Access Microsoft 365 Services
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 11:37 EDT
Update
Microsoft reports a change has been made and they are seeing signs of recovery. They continue to monitor network health to ensure full remediation.
Posted Sep 12, 2024 - 10:20 EDT
Update
Microsoft reports they are continuing remediation efforts to address this issue. Our team continues to monitor the situation for further updates.
Posted Sep 12, 2024 - 09:54 EDT
Monitoring
Microsoft has reported they are investigating an issue where some users are unable to access Microsoft 365 services. Our team is monitoring the situation.
Posted Sep 12, 2024 - 08:46 EDT