CCH Axcess Performance Issues

Incident Report for Rightworks Premier

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 11:47 EDT

Update

CCH advises affected users to fully close and then reopen CCH Axcess. This action should resolve the reported issues. For the latest updates, please visit https://support.cch.com/oss/ml/appstatus.
Posted Apr 14, 2026 - 10:52 EDT

Monitoring

CCH is aware of reported performance issues affecting CCH Axcess and is actively reviewing the situation. For ongoing updates, please visit https://support.cch.com/oss/ml/appstatus.
Posted Apr 14, 2026 - 10:38 EDT

Investigating

Several firms have have reported CCH Axcess outages, latency, application errors, and dashboard access failures. Some users are encountering error codes (e.g., 50402) when launching Tax through Axcess. We will provide further updates as more information becomes available.
Posted Apr 14, 2026 - 10:32 EDT